import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "N(?:e(?:w(?:\\s+(?:Y(?:o(?:r(?:k)?)?)?)?)?)?)?$";
final String string = "How much new sales in new\n"
+ "How much new sales in new yo\n"
+ "How much new sales in new yor";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}