using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">[ \n]*?(.+)[ \n]*?<";
string input = @"product-title"" role=""link"">
Cast Iron Square Grill Pan - 10.5 Inch Pre-Seasoned Skillet with...
</span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}