// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)>[ \n]*?(.+)[ \n]*?<").unwrap();
let string = "product-title\" role=\"link\">
Cast Iron Square Grill Pan - 10.5 Inch Pre-Seasoned Skillet with...
</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}