package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)>[ \n]*?(.+)[ \n]*?<`)
var str = `product-title" role="link">
Cast Iron Square Grill Pan - 10.5 Inch Pre-Seasoned Skillet with...
</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}