re = />[ \n]*?(.+)[ \n]*?</m
str = 'product-title" role="link">
Cast Iron Square Grill Pan - 10.5 Inch Pre-Seasoned Skillet with...
</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end