$re = '/>[ \n]*?(.+)[ \n]*?</m';
$str = 'product-title" role="link">
Cast Iron Square Grill Pan - 10.5 Inch Pre-Seasoned Skillet with...
</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);