const regex = new RegExp(':(?P<key>[\\w-]+): (?P<value>.+)', 'gm')
const str = `
:env-wirecard:
:domain: wirecard.com
:documentation-url: doc.{domain}
:payment-gateway-abbr: WPG
:payment-page-abbr: WPP
:payment-page-anchor: WPP
:payment-page-abbr-lower-case: wpp
:payment-provider-name-lower-case: wirecard
:payment-provider-name: Wirecard
:mermaid-config: config/mermaid-default-theme.json
:payment-redirect-url-hostname: www.wirecard.com
:api-id: wpp
:checkout-page-html-hostname: www.wirecard.com
:payment-page-function-short: WPP
:payment-page-function: WirecardPaymentPage
:pay-button-name: wirecard
:three-d-s-pw: wirecard
:3dsecure-test-instance-hostname: 3dsecure-test.{domain}
:data-warehouse: {payment-provider-name} Data Warehouse
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}