import Foundation
let pattern = #":(?P<key>[\w-]+): (?P<value>.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
:env-wirecard:
:domain: wirecard.com
:documentation-url: doc.{domain}
:payment-gateway-abbr: WPG
:payment-page-abbr: WPP
:payment-page-anchor: WPP
:payment-page-abbr-lower-case: wpp
:payment-provider-name-lower-case: wirecard
:payment-provider-name: Wirecard
:mermaid-config: config/mermaid-default-theme.json
:payment-redirect-url-hostname: www.wirecard.com
:api-id: wpp
:checkout-page-html-hostname: www.wirecard.com
:payment-page-function-short: WPP
:payment-page-function: WirecardPaymentPage
:pay-button-name: wirecard
:three-d-s-pw: wirecard
:3dsecure-test-instance-hostname: 3dsecure-test.{domain}
:data-warehouse: {payment-provider-name} Data Warehouse
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)