re = /:(?P<key>[\w-]+): (?P<value>.+)/m
str = '
:env-wirecard:
:domain: wirecard.com
:documentation-url: doc.{domain}
:payment-gateway-abbr: WPG
:payment-page-abbr: WPP
:payment-page-anchor: WPP
:payment-page-abbr-lower-case: wpp
:payment-provider-name-lower-case: wirecard
:payment-provider-name: Wirecard
:mermaid-config: config/mermaid-default-theme.json
:payment-redirect-url-hostname: www.wirecard.com
:api-id: wpp
:checkout-page-html-hostname: www.wirecard.com
:payment-page-function-short: WPP
:payment-page-function: WirecardPaymentPage
:pay-button-name: wirecard
:three-d-s-pw: wirecard
:3dsecure-test-instance-hostname: 3dsecure-test.{domain}
:data-warehouse: {payment-provider-name} Data Warehouse
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end