# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r":(?P<key>[\w-]+): (?P<value>.+)"
test_str = ("\n"
":env-wirecard:\n\n"
":domain: wirecard.com\n"
":documentation-url: doc.{domain}\n"
":payment-gateway-abbr: WPG\n"
":payment-page-abbr: WPP\n"
":payment-page-anchor: WPP\n"
":payment-page-abbr-lower-case: wpp\n"
":payment-provider-name-lower-case: wirecard\n"
":payment-provider-name: Wirecard\n"
":mermaid-config: config/mermaid-default-theme.json\n"
":payment-redirect-url-hostname: www.wirecard.com\n"
":api-id: wpp\n"
":checkout-page-html-hostname: www.wirecard.com\n"
":payment-page-function-short: WPP\n"
":payment-page-function: WirecardPaymentPage\n"
":pay-button-name: wirecard\n"
":three-d-s-pw: wirecard\n\n"
":3dsecure-test-instance-hostname: 3dsecure-test.{domain}\n"
":data-warehouse: {payment-provider-name} Data Warehouse\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.