// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):(?P<key>[\w-]+): (?P<value>.+)").unwrap();
let string = "
:env-wirecard:
:domain: wirecard.com
:documentation-url: doc.{domain}
:payment-gateway-abbr: WPG
:payment-page-abbr: WPP
:payment-page-anchor: WPP
:payment-page-abbr-lower-case: wpp
:payment-provider-name-lower-case: wirecard
:payment-provider-name: Wirecard
:mermaid-config: config/mermaid-default-theme.json
:payment-redirect-url-hostname: www.wirecard.com
:api-id: wpp
:checkout-page-html-hostname: www.wirecard.com
:payment-page-function-short: WPP
:payment-page-function: WirecardPaymentPage
:pay-button-name: wirecard
:three-d-s-pw: wirecard
:3dsecure-test-instance-hostname: 3dsecure-test.{domain}
:data-warehouse: {payment-provider-name} Data Warehouse
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}