using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,2}.\d{2}|\d{1,2}";
string input = @"Albania 10.00% Ethiopia 20.34% Libya 40.22% El Salvador 60.99%
Argentina 9.00% France 0.89% Luxembourg 42% Serbia 1.50%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}