// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2}.\d{2}|\d{1,2}").unwrap();
let string = "Albania 10.00% Ethiopia 20.34% Libya 40.22% El Salvador 60.99%
Argentina 9.00% France 0.89% Luxembourg 42% Serbia 1.50%";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}