import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,2}.\\d{2}|\\d{1,2}";
final String string = "Albania 10.00% Ethiopia 20.34% Libya 40.22% El Salvador 60.99%\n"
+ "Argentina 9.00% France 0.89% Luxembourg 42% Serbia 1.50%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}