const regex = /\d{1,2}.\d{2}|\d{1,2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}.\\d{2}|\\d{1,2}', 'gm')
const str = `Albania 10.00% Ethiopia 20.34% Libya 40.22% El Salvador 60.99%
Argentina 9.00% France 0.89% Luxembourg 42% Serbia 1.50%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}