re = /\d{1,2}.\d{2}|\d{1,2}/m
str = 'Albania 10.00% Ethiopia 20.34% Libya 40.22% El Salvador 60.99%
Argentina 9.00% France 0.89% Luxembourg 42% Serbia 1.50%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end