#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{10,100})[^)(\n]*(?:\(?[^)(\n]*\))?[^)(\n]*$"
Local $sString = "234234" & @CRLF & _
"234234" & @CRLF & _
"2222()234" & @CRLF & _
"sdf(asd)df" & @CRLF & _
"234((2342" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")