$re = '/^(?=.{10,100})[^)(\n]*(?:\(?[^)(\n]*\))?[^)(\n]*$/m';
$str = '234234
234234
2222()234
sdf(asd)df
234((2342
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);