import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{10,100})[^)(\\n]*(?:\\(?[^)(\\n]*\\))?[^)(\\n]*$";
final String string = "234234\n"
+ "234234\n"
+ "2222()234\n"
+ "sdf(asd)df\n"
+ "234((2342\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}