using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{10,100})[^)(\n]*(?:\(?[^)(\n]*\))?[^)(\n]*$";
string input = @"234234
234234
2222()234
sdf(asd)df
234((2342
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}