re = /^(?=.{10,100})[^)(\n]*(?:\(?[^)(\n]*\))?[^)(\n]*$/m
str = '234234
234234
2222()234
sdf(asd)df
234((2342
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end