#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\bj(oe\.)?smith@)(?=.*\ba(lly\.)?cat@)(?=.*\bb(ob\.)?builder@)(?=.*\bc(harleston\.)?chew@)(?!.*@(?!domain\.com\b))"
Local $sString = "=== MATCH ===" & @CRLF & _
"joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com" & @CRLF & _
"bob.builder@domain.com, cchew@domain.com, joe.smith@domain.com, acat@domain.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"=== NO MATCH ===" & @CRLF & _
"joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.comm" & @CRLF & _
"joe.smith@doman.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com" & @CRLF & _
"joe.smith@domain.com, acat@domain.com, bob.builderdomain.com, cchew@domain.com" & @CRLF & _
"joe.smith@domains.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com" & @CRLF & _
"jjoe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")