$re = '/^(?=.*\bj(oe\.)?smith@)(?=.*\ba(lly\.)?cat@)(?=.*\bb(ob\.)?builder@)(?=.*\bc(harleston\.)?chew@)(?!.*@(?!domain\.com\b))/m';
$str = '=== MATCH ===
joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
bob.builder@domain.com, cchew@domain.com, joe.smith@domain.com, acat@domain.com
=== NO MATCH ===
joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.comm
joe.smith@doman.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
joe.smith@domain.com, acat@domain.com, bob.builderdomain.com, cchew@domain.com
joe.smith@domains.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
jjoe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);