import Foundation
let pattern = #"^(?=.*\bj(oe\.)?smith@)(?=.*\ba(lly\.)?cat@)(?=.*\bb(ob\.)?builder@)(?=.*\bc(harleston\.)?chew@)(?!.*@(?!domain\.com\b))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
=== MATCH ===
joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
bob.builder@domain.com, cchew@domain.com, joe.smith@domain.com, acat@domain.com
=== NO MATCH ===
joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.comm
joe.smith@doman.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
joe.smith@domain.com, acat@domain.com, bob.builderdomain.com, cchew@domain.com
joe.smith@domains.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
jjoe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)