# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.*\bj(oe\.)?smith@)(?=.*\ba(lly\.)?cat@)(?=.*\bb(ob\.)?builder@)(?=.*\bc(harleston\.)?chew@)(?!.*@(?!domain\.com\b))"
test_str = ("=== MATCH ===\n"
"joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com\n"
"bob.builder@domain.com, cchew@domain.com, joe.smith@domain.com, acat@domain.com\n\n\n"
"=== NO MATCH ===\n"
"joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.comm\n"
"joe.smith@doman.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com\n"
"joe.smith@domain.com, acat@domain.com, bob.builderdomain.com, cchew@domain.com\n"
"joe.smith@domains.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com\n"
"jjoe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.