using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\bj(oe\.)?smith@)(?=.*\ba(lly\.)?cat@)(?=.*\bb(ob\.)?builder@)(?=.*\bc(harleston\.)?chew@)(?!.*@(?!domain\.com\b))";
string input = @"=== MATCH ===
joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
bob.builder@domain.com, cchew@domain.com, joe.smith@domain.com, acat@domain.com
=== NO MATCH ===
joe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.comm
joe.smith@doman.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
joe.smith@domain.com, acat@domain.com, bob.builderdomain.com, cchew@domain.com
joe.smith@domains.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com
jjoe.smith@domain.com, acat@domain.com, bob.builder@domain.com, cchew@domain.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}