import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "__\\([\\s]?'([^']*?)'[\\s]?\\)";
final String string = "$schedules['fiveminute'] = array(\n"
+ " 'interval' => 300,\n"
+ " 'display' => __('Every 5 minutes')\n"
+ ");\n"
+ "return $schedules;\n\n"
+ "return array(\n"
+ " 'success' => true,\n"
+ " 'msg' => __('Your password have updated successfull. You can login with your new password now.', ET_DOMAIN)\n"
+ ");";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}