import Foundation
let pattern = #"__\([\s]?'([^']*?)'[\s]?\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$schedules['fiveminute'] = array(
'interval' => 300,
'display' => __('Every 5 minutes')
);
return $schedules;
return array(
'success' => true,
'msg' => __('Your password have updated successfull. You can login with your new password now.', ET_DOMAIN)
);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)