# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/_(?![^_]+_[^_]+$)/./gi;t' <<< "john_smith_domain_com"