const regex = new RegExp('_(?![^_]+_[^_]+$)', 'gi')
const str = `john_smith_domain_com`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);