import re
regex = re.compile(r"_(?![^_]+_[^_]+$)", flags=re.IGNORECASE)
test_str = "john_smith_domain_com"
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)