using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_(?![^_]+_[^_]+$)";
string substitution = @".";
string input = @"john_smith_domain_com";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}