$re = '/_(?![^_]+_[^_]+$)/i';
$str = 'john_smith_domain_com';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;