#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:[^A-Z\n]*[A-Z]){2,4}[^A-Z\n]*$).{6,12}$"
Local $sString = "Valid matches would be:" & @CRLF & _
"" & @CRLF & _
"HamBurger" & @CRLF & _
"LeTtUce" & @CRLF & _
"TACOss" & @CRLF & _
"" & @CRLF & _
"But invalid matches would be:" & @CRLF & _
"" & @CRLF & _
"ABCDE1234" & @CRLF & _
"aBcDeFgHiJ" & @CRLF & _
"ADBC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")