import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:[^A-Z\\n]*[A-Z]){2,4}[^A-Z\\n]*$).{6,12}$";
final String string = "Valid matches would be:\n\n"
+ "HamBurger\n"
+ "LeTtUce\n"
+ "TACOss\n\n"
+ "But invalid matches would be:\n\n"
+ "ABCDE1234\n"
+ "aBcDeFgHiJ\n"
+ "ADBC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}