import re
regex = re.compile(r"^(?=(?:[^A-Z\n]*[A-Z]){2,4}[^A-Z\n]*$).{6,12}$", flags=re.MULTILINE)
test_str = ("Valid matches would be:\n\n"
"HamBurger\n"
"LeTtUce\n"
"TACOss\n\n"
"But invalid matches would be:\n\n"
"ABCDE1234\n"
"aBcDeFgHiJ\n"
"ADBC")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")