package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(\.|,)?\d*$`)
var str = `a1
a1.2
1.2b
1a.2b
1,2
123.455
12.45.
12.2.1
.1.2.2
123
1
2
2.3
2.3.4
2,3.4
2.,4
124
.4
0.4
,4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}