import re
regex = re.compile(r"^\d+(\.|,)?\d*$", flags=re.MULTILINE)
test_str = ("a1\n"
"a1.2\n"
"1.2b\n"
"1a.2b\n"
"1,2\n"
"123.455\n"
"12.45.\n"
"12.2.1\n"
".1.2.2\n"
"123\n"
"1\n"
"2\n"
"2.3\n"
"2.3.4\n\n"
"2,3.4\n"
"2.,4\n"
"124\n\n"
".4\n"
"0.4\n"
",4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")