re = /^\d+(\.|,)?\d*$/m
str = 'a1
a1.2
1.2b
1a.2b
1,2
123.455
12.45.
12.2.1
.1.2.2
123
1
2
2.3
2.3.4
2,3.4
2.,4
124
.4
0.4
,4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end