use strict;
my $str = 'a1
a1.2
1.2b
1a.2b
1,2
123.455
12.45.
12.2.1
.1.2.2
123
1
2
2.3
2.3.4
2,3.4
2.,4
124
.4
0.4
,4';
my $regex = qr/^\d+(\.|,)?\d*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}