import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(\\.|,)?\\d*$";
final String string = "a1\n"
+ "a1.2\n"
+ "1.2b\n"
+ "1a.2b\n"
+ "1,2\n"
+ "123.455\n"
+ "12.45.\n"
+ "12.2.1\n"
+ ".1.2.2\n"
+ "123\n"
+ "1\n"
+ "2\n"
+ "2.3\n"
+ "2.3.4\n\n"
+ "2,3.4\n"
+ "2.,4\n"
+ "124\n\n"
+ ".4\n"
+ "0.4\n"
+ ",4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}