using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)].*";
string substitution = @"[$1:$2][$3:$4][$5:$6]";
string input = @"City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}