$re = '/.*\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)].*/';
$str = 'City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:';
$subst = "[$1:$2][$3:$4][$5:$6]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;