re = /.*\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)].*/
str = 'City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:'
subst = '[$1:$2][$3:$4][$5:$6]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result