use strict;
my $str = 'City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:';
my $regex = qr/.*\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)].*/p;
my $subst = '[$1:$2][$3:$4][$5:$6]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";