package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)]\s*\[name:([A-Z]+)]\[distance:(\d+)].*`)
var str = `City: [name:NYK][distance:1100] [name:CLT][distance:2300] [name:KTY][distance:3540] Price:`
var substitution = "[$1:$2][$3:$4][$5:$6]"
fmt.Println(re.ReplaceAllString(str, substitution))
}