#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^" & @CRLF & _
" (?: no \s)? # not "no "" & @CRLF & _
" ( # capture it" & @CRLF & _
" (?: \S{1,2} \s )? # optional: 1-2 non whitespace characters and one space, BUT NOT GET "no " (it doesn't works)" & @CRLF & _
" \S+ # non whitespace characters" & @CRLF & _
" )" & @CRLF & _
"$"
Local $sString = "ab123" & @CRLF & _
"ab 123" & @CRLF & _
"no abc123" & @CRLF & _
"no ab 123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")