const regex = /^
(?: no \s)? # not "no "
( # capture it
(?: \S{1,2} \s )? # optional: 1-2 non whitespace characters and one space, BUT NOT GET "no " (it doesn't works)
\S+ # non whitespace characters
)
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?: no \\s)? # not "no "
( # capture it
(?: \\S{1,2} \\s )? # optional: 1-2 non whitespace characters and one space, BUT NOT GET "no " (it doesn\'t works)
\\S+ # non whitespace characters
)
$', 'gm')
const str = `ab123
ab 123
no abc123
no ab 123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}