re = /^
(?: no \s)? # not "no "
( # capture it
(?: \S{1,2} \s )? # optional: 1-2 non whitespace characters and one space, BUT NOT GET "no " (it doesn't works)
\S+ # non whitespace characters
)
$/xm
str = 'ab123
ab 123
no abc123
no ab 123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end