import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " (?: no \\s)? # not \"no \"\n"
+ " ( # capture it\n"
+ " (?: \\S{1,2} \\s )? # optional: 1-2 non whitespace characters and one space, BUT NOT GET \"no \" (it doesn't works)\n"
+ " \\S+ # non whitespace characters\n"
+ " )\n"
+ "$";
final String string = "ab123\n"
+ "ab 123\n"
+ "no abc123\n"
+ "no ab 123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}